Home  | FAQ  | Search  | Memberlist  | Usergroups  | Register  | Profile  | Log in  | Log in for your private messages
Add custom smilies to myBloggie?

 
Post new topic   Reply to topic    myWebland Forum Index -> Customization
View previous topic :: View next topic  
Author Message
squarefrog
Newbie


Joined: 05 Aug 2005
Posts: 8
Location: England

PostPosted: Fri Aug 05, 2005 9:39 am    Post subject: Add custom smilies to myBloggie? Reply with quote

Firstly, thanks for all your hard work. Your myBloggie project is wonderful!

Secondly, is there any way to add custom smilies/emoticons in myBloggie? I want to add icon_star.gif to be used when I type :star:, and I just wondered if this was possible.

Keep up the good work!
_________________
SquareFrog
SquareBlog
Back to top
View user's profile Send private message Visit poster's website
Canad1an
Developer


Joined: 11 Jun 2005
Posts: 83

PostPosted: Fri Aug 05, 2005 4:53 pm    Post subject: Reply with quote

I will work on a mod for this.
_________________
www.canad1an.com

P.S. This is what part of the alphabet would look like with Q and R eliminated.
---------------------------------------------------
-matt
Back to top
View user's profile Send private message Visit poster's website AIM Address
Canad1an
Developer


Joined: 11 Jun 2005
Posts: 83

PostPosted: Sat Aug 06, 2005 5:20 am    Post subject: Reply with quote

PROJECT UNDERWAY - BUGS EXPECTED, please wait for stable release.


Here you are...

http://www.canad1an.com/mybloggie/download.php?filename=Smilies_Patch

Download that. Overwrite the files. And you are done.

To add smiles:

Open 'smilies.txt' (in 'includes' folder)

the format is:

COMMAND*x*FILE

Ex.
:-)*x*smile.gif

The :-) determines what command to initiate the smilie.
The *x* is simply a separator.
The smile.gif is the name of the file. Which is located in the 'smilies' directory

Upload your smilies to the smiliey directory, and change the 'smilies.txt' file as stated above.

Hope this helps...
_________________
www.canad1an.com

P.S. This is what part of the alphabet would look like with Q and R eliminated.
---------------------------------------------------
-matt


Last edited by Canad1an on Sun Aug 07, 2005 6:05 am; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website AIM Address
squarefrog
Newbie


Joined: 05 Aug 2005
Posts: 8
Location: England

PostPosted: Sat Aug 06, 2005 6:00 pm    Post subject: Reply with quote

Thanks for that, the only problem now is when I log in i get
Quote:
Template->make_filename(): Error - file templates/aura/admin/all_com.tpl does not exist

Which is correct, as the file doesnt exsist, either locally or on my server. Any where to download it? Also from looking at the source of admin.php I guess I'll need all_com.php too.

Cheers!
_________________
SquareFrog
SquareBlog
Back to top
View user's profile Send private message Visit poster's website
Canad1an
Developer


Joined: 11 Jun 2005
Posts: 83

PostPosted: Sat Aug 06, 2005 6:03 pm    Post subject: Reply with quote

I recommend redownloading mybloggie and adding any files that you do not have to your directory. Be sure to place them in the correct area.
_________________
www.canad1an.com

P.S. This is what part of the alphabet would look like with Q and R eliminated.
---------------------------------------------------
-matt
Back to top
View user's profile Send private message Visit poster's website AIM Address
squarefrog
Newbie


Joined: 05 Aug 2005
Posts: 8
Location: England

PostPosted: Sat Aug 06, 2005 6:09 pm    Post subject: Reply with quote

Sure thing..

Thanks.

:EDIT: Oh I see what the problem is now - I'm using myBloggie 2.1.2, and the files it asks for are only included with 2.1.3 beta.. looks like i'll be upgrading then.
_________________
SquareFrog
SquareBlog
Back to top
View user's profile Send private message Visit poster's website
squarefrog
Newbie


Joined: 05 Aug 2005
Posts: 8
Location: England

PostPosted: Sat Aug 06, 2005 8:20 pm    Post subject: Reply with quote

OK that works thanks, but there is a bug in it. If I preview the message, all the emoticons come up as broken links, but if I submit then view the message they work fine. Not a big issue, I can probably live with that!
_________________
SquareFrog
SquareBlog
Back to top
View user's profile Send private message Visit poster's website
Canad1an
Developer


Joined: 11 Jun 2005
Posts: 83

PostPosted: Sun Aug 07, 2005 5:45 am    Post subject: Reply with quote

bleh, so much for sleeping tonight. I will have that fixed soon...
_________________
www.canad1an.com

P.S. This is what part of the alphabet would look like with Q and R eliminated.
---------------------------------------------------
-matt
Back to top
View user's profile Send private message Visit poster's website AIM Address
Canad1an
Developer


Joined: 11 Jun 2005
Posts: 83

PostPosted: Sun Aug 07, 2005 6:03 am    Post subject: Reply with quote

Actually there is a few more bugs then that....the edit does not work as well....let me fix and I will release a patch for you, and the main files for all....for now, smilie patch is closed.
_________________
www.canad1an.com

P.S. This is what part of the alphabet would look like with Q and R eliminated.
---------------------------------------------------
-matt
Back to top
View user's profile Send private message Visit poster's website AIM Address
squarefrog
Newbie


Joined: 05 Aug 2005
Posts: 8
Location: England

PostPosted: Sun Aug 07, 2005 4:18 pm    Post subject: Reply with quote

Seriously man, if its hassle, dont worry about it. I know what the post is going to look like from the preview, and if i have to edit and the edit function doesnt work, i can just edit the table row in phpmyadmin.

You've done more than enough for me already Smile get some sleep!
_________________
SquareFrog
SquareBlog
Back to top
View user's profile Send private message Visit poster's website
Canad1an
Developer


Joined: 11 Jun 2005
Posts: 83

PostPosted: Thu Aug 11, 2005 12:58 pm    Post subject: Reply with quote

bleh...soon, i'm so busy right now
_________________
www.canad1an.com

P.S. This is what part of the alphabet would look like with Q and R eliminated.
---------------------------------------------------
-matt
Back to top
View user's profile Send private message Visit poster's website AIM Address
squarefrog
Newbie


Joined: 05 Aug 2005
Posts: 8
Location: England

PostPosted: Sun Sep 04, 2005 4:02 pm    Post subject: Reply with quote

I've just noticed that when using this custom smilie malarky, if you look at any of the archived posts (either searching, clicking on a category or a date etc) none of the emoticons display.

I'm just going to delete all the custom files/reinstall my bloggie and use img tags instead.. much less hassle Smile

:EDIT: oh that didnt work.. the images are displayed like this :
*
*
*
instead of ***
_________________
SquareFrog
SquareBlog
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    myWebland Forum Index -> Customization All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
TNX?

Error. Page cannot be displayed. Please contact your service provider for more details. (32)




Powered by phpBB © 2001, 2005 phpBB Group
Contact Us