Home  | FAQ  | Search  | Memberlist  | Usergroups  | Register  | Profile  | Log in  | Log in for your private messages
RSS available indicator in MSIE 7.2 Beta

 
Post new topic   Reply to topic    myWebland Forum Index -> Support
View previous topic :: View next topic  
Author Message
hhb
Newbie


Joined: 17 Apr 2006
Posts: 4

PostPosted: Tue Apr 25, 2006 5:34 pm    Post subject: RSS available indicator in MSIE 7.2 Beta Reply with quote

Hello, the 7.2 beta version of MSIE has an icon for RSS availability on webpages surfed. The icon lights up if a feed is available, then allows subscription, etc. and viewing in the browser.

When visiting the network news sites, such as cnn or abc, the RSS icon turns on. However, when visiting the myBloggie webpage I set up previously, the RSS icon does not light up/activate. The feed pages there validate, work fine.

Any suggestions about what the coding difference could be between a network news site and myBloggie that allows the MSIE beta 7.2 to recognize the feed availability in one instance and not in the other? XML coding for both circumstances appears identical.

Thanks for any help -- hhb
Back to top
View user's profile Send private message
simpleguest
Junior Coder


Joined: 15 Aug 2005
Posts: 50

PostPosted: Sun Apr 30, 2006 1:15 pm    Post subject: Reply with quote

In blog_header.tpl find lines which countain <link rel="alternate" type="application/rss+xml" [...] and see if they're similar to these:

Code:
<link rel="alternate" type="application/rss+xml" title="RSS .92" href="http://yoursite.com//rss/rss.php" />
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="http://yoursite.com/rss/rss2.php" />


Dont forget to change links!
Back to top
View user's profile Send private message Visit poster's website
hhb
Newbie


Joined: 17 Apr 2006
Posts: 4

PostPosted: Sun Apr 30, 2006 4:14 pm    Post subject: Checks out okay Reply with quote

Thanks for the reply. Checked the style code on the header template, it reads:

<link rel="alternate" type="text/xml" title="RSS .92" href="{RSS_URL}" />
<link rel="alternate" type="text/xml" title="RSS 2.0" href="{RSS2_URL}" />

When visiting the blog, source code for the page reads:

<link rel="alternate" type="text/xml" title="RSS .92" href="http://site.com/blog/rss/rss.php" />
<link rel="alternate" type="text/xml" title="RSS 2.0" href="http://site.com/blog/rss/rss2.php" />

which is accurate. As said, the rss/rss2 feeds validate okay. I also have a php page that fetches rss feeds -- 10 most recent post titles/post short description blurbs linked. It works fine.

What doesn't work is the MSIE Beta 7.2's "rss feed recognition" feature. Its "feed available" icon doesn't light up when visiting the blog. Visiting network news pages (i.e., abc, nbc, cbs, cnn) with available rss feeds DOES light up the Beta's feed available icon. The Beta also has a "subscribe" feature when the "rss feed available" icon lights up. It doesn't seem to work either.

Have noticed other differences when using the Beta version -- it doesn't even read simple html code correctly in some instances, for example, so maybe this is just a Beta bug thing. Hope they get the new browser straightened out before everyone has to use it ....

Thanks again -- hhb
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    myWebland Forum Index -> Support All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
TNX?

Error. Page cannot be displayed. Please contact your service provider for more details. (17)




Powered by phpBB © 2001, 2005 phpBB Group
Contact Us