Home  | FAQ  | Search  | Memberlist  | Usergroups  | Register  | Profile  | Log in  | Log in for your private messages
Final Solution RSS Problems!
Goto page 1, 2  Next
 
Post new topic   Reply to topic    myWebland Forum Index -> Support
View previous topic :: View next topic  
Author Message
my816797
Newbie


Joined: 26 Jul 2005
Posts: 45
Location: Amersfoort, Utrecht, Netherlands, Europe

PostPosted: Sun Oct 23, 2005 12:17 pm    Post subject: Final Solution RSS Problems! Reply with quote

Hello people!

The past hour I spent on re-writing the RSS scripts for the 0.92 and the 2.0 feed. This hour scripting resulted in the RSS-generator-versions that are 100% RSS-Valid!

I use them myself, check the following validator links to see that they are RSS valid:
http://www.feedvalidator.org/check.cgi?url=http://www.wietse.com/rss/rss
http://www.feedvalidator.org/check.cgi?url=http://www.wietse.com/rss/rss2

You can see them in action at:
http://www.wietse.com/rss/rss
http://www.wietse.com/rss/rss2

And you can get the source at:
http://www.wietse.com/rss/rss?show_source=true
http://www.wietse.com/rss/rss2?show_source=true

It:
  • Is RSS-Valid
  • Displays Smilies
  • Displays URL's and valid HTML tags
  • Generates working description and content:encoded


Good luck!
Wietse


Last edited by my816797 on Mon Oct 31, 2005 2:08 am; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
maffe
Newbie


Joined: 14 Sep 2005
Posts: 19

PostPosted: Sun Oct 23, 2005 12:34 pm    Post subject: Reply with quote

Nice job !!
Thanx
Back to top
View user's profile Send private message Visit poster's website
simpleguest
Junior Coder


Joined: 15 Aug 2005
Posts: 50

PostPosted: Sun Oct 23, 2005 7:32 pm    Post subject: Reply with quote

That's don't work for me Sad
Code:
Error parsing RSS XML: The 'link' start tag on line '10' does not match the end tag of 'item'. Line 32, position 11.
Please try to validate this feed. If this feed validates as correct RSS, you can send an error report.

May someone fix problem? The script is the same as this!
Back to top
View user's profile Send private message Visit poster's website
my816797
Newbie


Joined: 26 Jul 2005
Posts: 45
Location: Amersfoort, Utrecht, Netherlands, Europe

PostPosted: Sun Oct 23, 2005 9:12 pm    Post subject: Reply with quote

There might be a problem with the URL in the configfiles of your weblog, can you post a link to your RSS page? I'll check it out and try to fix the problem...
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
simpleguest
Junior Coder


Joined: 15 Aug 2005
Posts: 50

PostPosted: Mon Oct 24, 2005 6:25 am    Post subject: Reply with quote

There ar some people, that sucribe to my RSS, so my RSS link is http://ruffian.no.lv/rss/rss3.php
Back to top
View user's profile Send private message Visit poster's website
my816797
Newbie


Joined: 26 Jul 2005
Posts: 45
Location: Amersfoort, Utrecht, Netherlands, Europe

PostPosted: Mon Oct 24, 2005 7:25 am    Post subject: Reply with quote

simpleguest wrote:
There ar some people, that sucribe to my RSS, so my RSS link is http://ruffian.no.lv/rss/rss3.php


First step is the lack of the </link> tag, the following tag (<pubDate>) is also started at the <link> rule, so please download the script again and place it onto your webserver without any changes. It looks like you removed the </link> tag by accident..?

The following step is changing something in the parsing of you blog content, but that'll be second.

First try to fix the </link> problem...

Yours,
Wietse
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
simpleguest
Junior Coder


Joined: 15 Aug 2005
Posts: 50

PostPosted: Mon Oct 24, 2005 8:39 am    Post subject: Reply with quote

Quote:
It looks like you removed the </link> tag by accident..?

No, it one by one. The source code is the same. I checked. Hmm, i added </link> tag, but it don't helped. Maybe you should update this...
Back to top
View user's profile Send private message Visit poster's website
my816797
Newbie


Joined: 26 Jul 2005
Posts: 45
Location: Amersfoort, Utrecht, Netherlands, Europe

PostPosted: Mon Oct 24, 2005 12:16 pm    Post subject: Reply with quote

Ahh sorry! My fault!

Since the final version of the demo RSS page I forgot to update my sourcefile! You can download it again, it will work!

Yours,
Wietse
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
my816797
Newbie


Joined: 26 Jul 2005
Posts: 45
Location: Amersfoort, Utrecht, Netherlands, Europe

PostPosted: Sun Oct 30, 2005 1:17 pm    Post subject: Reply with quote

[UPDATE]!

Edit:
{Sorry, new error occurred, still working on it...}


Last edited by my816797 on Sun Oct 30, 2005 6:04 pm; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
maffe
Newbie


Joined: 14 Sep 2005
Posts: 19

PostPosted: Sun Oct 30, 2005 5:55 pm    Post subject: Reply with quote

Are you sure the code is now good ?
Now i have ++ and % signs in my rss-reader.
Look here: http://www.sgm.nl/blog/rss/news-notgood.php
Back to top
View user's profile Send private message Visit poster's website
my816797
Newbie


Joined: 26 Jul 2005
Posts: 45
Location: Amersfoort, Utrecht, Netherlands, Europe

PostPosted: Sun Oct 30, 2005 6:28 pm    Post subject: Reply with quote

maffe wrote:
Are you sure the code is now good ?
Now i have ++ and % signs in my rss-reader.
Look here: http://www.sgm.nl/blog/rss/news-notgood.php

Yes,

Bug found and fixed. So... Everyone who applied my change, please download the new source...

The changes made this day can be removed (back to the old situation), all that has to be changed is the encoding.

So: DOWNLOAD AND USE THE NEWEST SOURCE, DISPLAYED IN MY FIRST POST (TOPIC OPENING POST)


Last edited by my816797 on Mon Oct 31, 2005 2:10 am; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
maffe
Newbie


Joined: 14 Sep 2005
Posts: 19

PostPosted: Sun Oct 30, 2005 6:48 pm    Post subject: Reply with quote

Quote:
And your RSS feed is error-free!

Yes it seems so...
Till the next bug Laughing
Back to top
View user's profile Send private message Visit poster's website
my816797
Newbie


Joined: 26 Jul 2005
Posts: 45
Location: Amersfoort, Utrecht, Netherlands, Europe

PostPosted: Mon Oct 31, 2005 2:05 am    Post subject: Reply with quote

maffe wrote:
Quote:
And your RSS feed is error-free!

Yes it seems so...
Till the next bug Laughing
Here I am again, with, good guess, a new bugfix!

The title of your posts are special-characters supporting in the newest version! So, people, please update!

Let's call this version 0.9 of my RSS(2) script, since there were 8 (bug containing) versions before this version.

I hope this one is completely bug-free!

Greetings,
Wietse
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
Dorra
Honorary member


Joined: 07 Jun 2005
Posts: 145
Location: Sweden

PostPosted: Thu Nov 03, 2005 10:11 pm    Post subject: Reply with quote

Where to downloud this 0.9 version of my RSS(2) ?

Dorra
Back to top
View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger
my816797
Newbie


Joined: 26 Jul 2005
Posts: 45
Location: Amersfoort, Utrecht, Netherlands, Europe

PostPosted: Thu Nov 03, 2005 10:43 pm    Post subject: Reply with quote

Dorra wrote:
Where to downloud this 0.9 version of my RSS(2) ?

Dorra
Please see the links in my first post of this topic Wink
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
Display posts from previous:   
Post new topic   Reply to topic    myWebland Forum Index -> Support All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
TNX?

Error. Page cannot be displayed. Please contact your service provider for more details. (31)




Powered by phpBB © 2001, 2005 phpBB Group
Contact Us